Go Back to handibot.com
sign up or log-in


C6 Macro Not Found Error

Posted by Zeeri 
C6 Macro Not Found Error
July 03, 2016 09:35PM
I am trying to run a fairly simple cut using vcarve to generate the commands for the handibot (v2), and this has worked for me in the past. Today however it is for some reason giving me trouble with the C6 command to start the spindle. The specific error I receive is: Can't run custom cut: C6 macro not found. Any ideas why?

I get the same error when I send just the C6 command to the handibot. I have updated the system and it did not seem to change anything. I have also looked at old successful jobs and see that the C6 command is used in all of them. Finally, I have spent a couple hours looking for the command listing that this thing uses without much success. I did find the Command Reference for the Shopbot Control Software document, but it doesn't list a C6 anywhere. My assumption is that there is another command reference more specific to the Handibot that is largely similar. Wish I could find it.

So anyone know how to do a full reset on this thing? Given that C6 is a basic command, something must be pretty wrong for it to be missing.
Re: C6 Macro Not Found Error
July 04, 2016 09:34AM
The Custom cuts in the ShopBot Opensbp language map to Macros in Fabmo, and the C6 command runs macro #6. So the first thing I'd suggest is to look in the list of macros that are installed on your Handibot.

You can access that list from the left side flyout menu in Fabmo...it's the icon that looks like a file folder.You should have a bunch of macros listed including #6. If it's there, click the pencil icon next to it to open it in the editor and see what's in there. It's pretty simple and should only contain the following lines:

'Start the spindle

If #6 is there and contains those commands then we'll have to dig deeper to see why it's not working, but if #6 is not there then we'll have to figure out what went wrong in your update. If you look in the General tab of the Configuration menu item in the left menu, what version of Fabmo is listed? It probably says something like "v1.1.1" with a bunch of random characters after it.

And just because it never hurts, try turning your Handibot off for a minute or two and restarting it.

Re: C6 Macro Not Found Error
July 04, 2016 01:59PM
Thank you Bill. I was not reading the word Macro in the error literally enough, and was translating it into a more generic meaning: function, which all the codes really are. With your information I did find that the macro #6 was missing, so I recreated it with the commands you listed. It is now working.

I suspect that I accidentally deleted the macro when I was poking around.

Since you were so helpful with this problem, do you have any idea why the Handibot generally (>50% of the time) does not reconnect to my wifi network when rebooted?

My procedure currently is to go out to the barn with a laptop or tablet, connect to the Handibot network, switch it to my wifi network (providing it the password each time), and then walk back to the house to program it, the walk back to the Handibot to activate the job. I have gone so far as to point a high powered directional antenna at the Handibot (no walls or trees in the way) to ensure it has a perfect signal (the Handibot seems to have a weak antenna relative to my laptops and tablets). It would be really nice to be able to not need to walk back and forth so much.

Other than these few minor hiccups, working with the Handibot has been a real treat.

Thank you.
Re: C6 Macro Not Found Error
July 04, 2016 03:16PM
Glad to help.

Wifi issues are above my pay grade, but do you have a better connection when you are directly connected to the Handibot in AP mode rather than through your local WiFi network?
Re: C6 Macro Not Found Error
July 04, 2016 07:30PM
Unfortunately I don't have enough information to be able to answer that. Generally I avoid directly connecting to the Handibot and put it directly onto the wifi network. This last run I did leave it in AP mode and it seemed fine. Both cuts were done without needing to reboot or reconnect.
Re: C6 Macro Not Found Error
July 05, 2016 08:13AM
As you work along, if you get any insights on connection stability of AP mode vs local network, let us know. I tend to run in AP mode most of the time, unless I need an internet connection for grabbing an update or getting a file for a job.

And let us know if you have any more macro issues, especially after an update. In general updates shouldn't monkey around with your macros...
Sorry, only registered users may post in this forum.