Go Back to handibot.com
sign up or log-in


"Waiting for Fabmo"

Posted by David Shay 
"Waiting for Fabmo"
June 23, 2017 09:47PM
Was just about to start another weekend of CNCing, and am running into some problems.

First, the router seemed to boot into AP mode. I was able to connect to it, ask it to join my home network, and it did so.
Then when it joined the home network, I was getting ready to install the new "Quick-Bit" app, but before I could even get there it just started to say "Waiting for Fabmo".

I can get into the updater, and it shows some interesting problems, such as the Engine status being "down" and version being unavailable.

I even went so far as to try a factory reset, but nothing worked.

There are some interesting errors in the console that read like this:

info: Checking for updates for FabMo-Updater [updater]
info: Checking online source for updates [fmp]
info: Retrieving a list of packages from [gofabmo.org] [fmp]
error: Error: Command failed: fatal: Not a git repository (or any of the parent directories): .git

    at ChildProcess.exithandler (child_process.js:658:15)
    at ChildProcess.emit (events.js:98:17)
    at maybeClose (child_process.js:766:16)
    at Process.ChildProcess._handle.onexit (child_process.js:833:5) [updater]
info: No new packages are available for linux/edison. [updater]

I can attach the log.txt from going to <ipaddr>:81/log, but those seem to be the relevant weird messages.

Anyone see this before?
Re: "Waiting for Fabmo"
June 25, 2017 01:00AM
Well, the good news is I got this resolved, but I never truly figured out the root cause. I had to take the Edison board out of the Handibot and re-flash it -- nothing else seemed to work.

Sure would be easier if there were a USB port actually wired up to that board instead of that procedure. For projects I've built with "Particle" (like an Arduino, with wifi), and others, in some cases I've wired up a USB port and connected it with a cable so you didn't have to disassemble the device in order to re-flash it. Just a recommendation for "v3"...
Re: "Waiting for Fabmo"
June 26, 2017 09:44AM

The "error" in the above log is not the heart of your issue, but I'm glad you got it resolved.

There is a factory reset procedure that you can perform, instead of a reflash, that will allow you to restore the state of your tool without reflashing over the USB. I will detail that in a separate post.

I know you are up and running again, but if I may ask, did you conduct a software update on your tool recently, before the crash?


Re: "Waiting for Fabmo"
June 26, 2017 01:56PM
Well, "conveniently" enough, it's in the same state. After reflashing it on Friday, I did go into the simple updater on Sunday, and it updated. Seemed to be working OK after that but likely didn't power off/on. Today, when we did so, it's in this same "broken" state.

What's the factory reset procedure? I tried clicking on the "Factory Reset" on the left hand side menu on the updater (:81) web page, and it said it was doing something, but it never seemed to reset or fix anything. Is there some "different" reset procedure?
Re: "Waiting for Fabmo"
June 26, 2017 03:10PM
Ryan has just uploaded a new version of the software to the server that sends updates to the tool. A factory reset followed by a normal update should set things right.

I've got instructions for performing the factory reset here: [www.dropbox.com]

Once complete, you'll need to connect your tool to a network to allow it to fetch the new software. When an update is ready, you'll be able to run the software update from the configurations menu.
Re: "Waiting for Fabmo"
June 26, 2017 06:07PM
Didn't work. Unfortunately, whatever state it's in, the "factory reset" doesn't seem to really do anything. It doesn't seem to really lose connectivity and/or take 5 minutes.

Also, when you run the simple updater it says it is up to date.

Updater page still says engine is "down".

Any other guesses?
Sorry, only registered users may post in this forum.