Go Back to handibot.com
sign up or log-in


FabMo update download?

Posted by Eric Schimelpfenig 
FabMo update download?
November 26, 2017 11:34AM
In the past I've done some updates to my Handibot which broke some macros that I had written. There was at some point a place that I could download the .FMC files so I could upgrade, and then downgrade my handibot if needed... I can't seem to find them anywhere... I even looked through GitHub to no avail... Does anyone know where I can find them?
Re: FabMo update download?
November 27, 2017 08:46AM
Hey Eric,

If you are looking for the .fmp files for current and past releases, you can find them at:


There's a shiny new version out, 1.6.0, that you'll see if you go there. Instructions for updating to that are available at:


Re: FabMo update download?
November 27, 2017 10:09AM
As noted by Bill Young, there is a major new update to Handibot's FabMo software. You can get it by going to this link:


Or, just by going to the docs website and clicking on the Bulletin link at the top.

We are moving towards updates being easily done (and notified on) the Configuration Manager screen that is available in the left side panel of FabMo. But, because this update is a little complex, it is best done through what we call the "Updater" ... the full process is explained in the instructions with the link.

This update should get any system that is at least at the 1.4.0 or later version of FabMo totally up to speed (You can check your version by going to the Configuration Manager screen and looking in the upper right corner or at the bottom of the drop-down menu). It includes latest default apps as well as macros.

If you have any problems give us a call or send a note to support.

Ted Hall, Handibot/ShopBot
Re: FabMo update download?
November 27, 2017 03:21PM
That's exactly what I was looking for. I had done some updates in the past through the updater that broke some of my SB scripts I was using. Having those FMC files will let me test out the new version, and give me the ability to roll back if I need to for some reason. Thanks!
Re: FabMo update download?
November 27, 2017 03:43PM
I'm having trouble accessing the update PDFs. The links seem broken.
Re: FabMo update download?
November 27, 2017 04:36PM
Website acting kinda funny--
'til we fix it--here they are
open | download - FabMo AP Update 1.6.0.pdf (951.5 KB)
open | download - Fabmo Internet Update 1.6.x.pdf (684.9 KB)
Re: FabMo update download?
November 28, 2017 10:50AM
The links are fixed!
Re: FabMo update download?
November 29, 2017 03:44AM
What a shambles!!!
The links are RomeoSierra, I could not upgrade from ver 1.4.3, and now Fabmo does not work at all, I just get a screen full of garbage. Get rid of your link to ver 1.5.
Then tell me how to fix this mess
Re: FabMo update download?
November 29, 2017 09:36AM
The PDF above has a link to the 1.6.0 consolidated update - if you download it and follow the instructions, things should start working again. If after the update, you're still getting garbage, can you take a screenshot and post here? We can figure out what's going on and get you right again.
Re: FabMo update download?
November 30, 2017 12:04AM
Hi Ryan,
Thanks for the swift response, and firstly let me apologize for the attitude in my previous post. I was at the end of my tether.

When I first open Fabmo I get the usual screen (Clipboard01.jpg), then when I click on the green button I get (Clipboard02.jpg).
I look forward to your response.
open | download - Clipboard01.jpg (50.5 KB)
open | download - Clipboard02.jpg (54 KB)
Re: FabMo update download?
December 01, 2017 01:14PM
OK all updated worked well. Only 1 problem is that I can not delete the duplicated apps Beamer, sketch, example, Hole cutter. I click and hold, red X comes up, click on red X and nothing happens ?
Re: FabMo update download?
December 01, 2017 04:45PM
Have you tried deleting both copies of the duplicate apps? The new fabmo update established a number of "built in" apps that were protected from deletion. Unfortunately some older copies of the apps remain along side the new (undelete-able) versions in the dashboard. I've found that it is possible to delete one copy but not the other.
Re: FabMo update download?
December 01, 2017 05:39PM
OK will try that
Re: FabMo update download?
December 04, 2017 07:28PM
Further to my previous posts, I tried using my iPhone7+ to talk to the Handibot and got the same garbled response.
That made me think that the problem is with the Handibot side of Fabmo, not the dashboard on my laptop.
If this is the case, how do I fix it?
Re: FabMo update download?
December 05, 2017 06:28PM
Hi Ryan,
Any luck on solving my problem?
Re: FabMo update download?
December 06, 2017 10:24AM

Can you post a screenshot of what you see when you visit [] - There should be a report of your tool versions there that we can use to determine the next step.

Re: FabMo update download?
December 06, 2017 01:09PM
My updater updated, but I can't get to the 1.6.1 engine. I don't see a *.fmp file on github (other than the release candidate) to do this manually either. Updater console gives notice of a 404 error in the following:

info: Checking for updates for FabMo-Engine [updater]
info: Checking online source for updates [fmp]
info: Retrieving a list of packages from [gofabmo.org] [fmp]
info: A newer package update is available! [fmp]
info: Starting download of [github.com] [fmp]
warn: There was a problem downloading a package: Error: 404 undefined [updater]
info: No new packages are available for linux/edison. [updater]
info: Package check complete. [updater]
Re: FabMo update download?
December 06, 2017 01:30PM
Oh--interesting. There was an .fmp there last night (which I actually tried to install but had other problems)--I would imagine that we're re-packaging the update and will have another version up shortly.
Re: FabMo update download?
December 06, 2017 02:11PM
We're having a little bit of difficulty with our build server at the moment - it should be back up later today, with the 1.6.1 fmp corrected on GH.

Sorry for the inconvenience!
Re: FabMo update download?
December 06, 2017 05:27PM
Here it is again(I sent it to you Nov 30)
open | download - Clipboard02.jpg (54 KB)
Re: FabMo update download?
December 07, 2017 09:15AM

This forum shortens the text of links - note that the link i posted is different than the address you posted a screenshot of. There's a :81 at the end of my link:


(The forum shortened the text of the link before - I have made an effort to have it display this time.

Edited 1 time(s). Last edit at 12/07/2017 12:20PM by Bill Young.
Re: FabMo update download?
December 07, 2017 03:02PM
Hi Ryan,
Screenshot attached as requested
open | download - Clipboard03.jpg (106 KB)
Re: FabMo update download?
December 08, 2017 03:19PM
Hey Wazza, Brian again.

It looks like your version of FabMo is struggling to update because it is such an early version. The fastest way to get up to a version that can take the update will be to reflash your card by connecting it directly to a computer using a USB cable. Instructions for completing the reflash are located here: [docs.handibot.com]
This process will get you up to the 1.4.2 version of the software--which we had been using up until the most recent update.
Please let me know if there is anything I can do to help with the reflash and update from here--I've done the process a number of times myself and have gotten comfortable with it.
Re: FabMo update download?
December 10, 2017 06:46PM
hello again,Brian,
No luck.
When I run flash.bat I get an abort message (see attached). I have checked the directory and the file in question is there.
Where to from here?
open | download - edison abort.jpg (35.8 KB)
Re: FabMo update download?
December 10, 2017 11:16PM
Back again, Brian,
I noticed in the abort message that the system apparently does not like usernames that contain spaces, so rather than edit the batch file I copied the zip file to my root directory and started again. Now it gives me this new message. I have run the DXU utility file as the administrator prior to executing flash.bat to get this far.
Over to you
open | download - Edison Abort MkII.jpg (36.1 KB)
Re: FabMo update download?
December 11, 2017 04:22PM

I'm trying to get some more info on that error. I have seen it before though, when I try to reflash boards on my beat up old laptop with sawdust in the USB ports. I hear the "connect" sound multiple times as it tries to connect the board and then ultimately fails.

Just to be sure...your board looks like the one in the photo shown in the document, right? with a set of little USB cables connecting to the red edison baseboard?
Also just to be sure--you're plugging into the OTG port and not the console, right?

For now, I'd recommend trying another USB port on your computer if it is available. I'll update with more info as soon as I have it.

Re: FabMo update download?
December 13, 2017 09:07PM
Hi Brian,
Yes, my board is same same yours, with "165" written on the Edison chip in blue Sharpie, if that might give a clue. I am plugging into the OTG port, have tried other USB ports on my laptop to no avail.
The link in the PDF file to "IntelDriverSetup1.2.1.exe" did not work (I had copied the file to my desktop, link lost) so I found it on Intel's website. I am hoping that this is not a problem. Whilst on that site I noticed others (IT types) having the same problem
Also, my extended base upgrade arrived yesterday, so I can look at designing a box to go underneath it for 4 & 5 axis stuff, etc., while this reflash problem is sorted. But the three screws referred to in the documentation for affixing the anti-backlash doo-hickey were not included. Can you give me their description? I will probably have some here somewhere.
Meantime, the extended upgrade looks very impressive, very keen to play with it. I might re-engineer something simple like a Harley Davidson! I have copyrighted the Hardly Dangerous name so don't nobody try jumpin' the gun!
As you USArians seem to be fond of saying,
Y'all have a nice day!
Re: FabMo update download?
December 14, 2017 12:06PM

I'm following the doc again and I re-downloaded the zip file with the reflash files. There should have been an executable to install the USB drivers for the edison...but it wasn't in the file I retrieved from the web. The communication error that you're getting may be due to a driver mismatch. I've uploaded another zip file with just the drivers on my wiki here: [sites.google.com]
There should be a 9MB exe file in there that will install the correct usb drivers to connect to your edison. If you could, try that and see if it clears up the communication issue.

PS--I do hope you have a nice day--though I'm not in the habit of demanding it of anyone!

Edited 1 time(s). Last edit at 12/14/2017 12:07PM by Brian Owen, ShopBot.
Re: FabMo update download?
December 14, 2017 02:20PM
Wazza, I just used the 3 screws from the old backlash on the original base. I think any of the motor mount screws work too.
Re: FabMo update download?
December 14, 2017 03:28PM
Oh yea-! whoops I forgot to respond to that. Yes you can use any of the M4x14 screws that were removed from the old base/bearings.

Thanks Dan.
Sorry, only registered users may post in this forum.