Go Back to handibot.com
sign up or log-in


Network woes

Posted by tagd 
Network woes
January 22, 2018 07:29PM
Last year I picked up a handibot and I've made a few things here and there with it, but didn't have a lot of time to really log a good solid project. This week I jumped into it, built a jig for sliding in material and was all set to go.

Then handibot started falling off the network. This is an 'adventure edition' device, and while the wifi was always a little weak, it sputtered out and never came back. Now what's interesting about this are a few things:

1. The wifi access point is a Linksys Velop, maybe 15' away from handibot.
2. My Surface tablet and phone both have 100% signal when placed on top of handibot.
3. My neighbor across the street gets 100% signal on my wifi from his house.

This all led me to believe that it was a handibot issue, so I turned it on-and-off a few times. It came back once, but died halfway through a cut, and then never came back.

Since then I've been on a mission to make this thing work again. But it's that kind of mission where there's a thing you ACTUALLY want to be doing (making stuff with your handibot) and instead you are doing this stupid thing (figuring out why it no longer works when nothing changed).

I'm a good tech guy, so I did the standard far-above-and-beyond troubleshooting.

1. Spinning the handibot device to face the other way in case there was interference.
2. Getting the wifi even closer even though signal strength was already good enough to roast a chicken.
3. Attempting a full reset
4. Finally this morning, pulling the Edison board and doing the full firmware reload.

As a side note, the diagrams for that process do not match my device, the process did not work for my device, and the only way I could get it to work was to plug the Edison components back in, disconnect the ribbon, reconnect my USB from my laptop and restart Handibot nearly a dozen times before it hooked and uploaded the firmware.

All of this resulted in 100% no change. My handibot was not on my network, and it was not putting up an AP to connect to.

So I did what you would normally do, I read a bunch of forum posts, waded through the mess of links to google drive files, out-of-date diagrams, inconsistent naming, and then ignored it all and ran an ethernet cable and plugged it into the port which is in no way referenced as existing in any of these documents.

My handibot immediately came back online. Now at version 1.42, I decided I should upgrade to 1.6 to make sure this wasn't just an old software problem. But luckily for me, I'm not done yet because:

1. The handibot can still not manage to attach to a wifi network that is so strong that I have to leave my city block to lose connection.
2. The perfectly good ethernet connection apparently doesn't count as an external access, and the device cannot update itself.

Did I mention at some point I was trying to do some CNC stuff, before I became a full-time network engineer?

So now I can at least cut some stuff with the ethernet connection, but it's very clear that stuff is still busted. There's no AP broadcast, there's no attempt to join the network according to my access point or my dhcp server, and generall the whole thing is stuck.

I'm going to hurry up and cut some things before the whole machine decides to surrender on me again, but if anyone has some thoughts on how I can turn this experiment back into a useful tool, I'd be open to any of them.
Re: Network woes
January 23, 2018 11:46AM

Thank you for that post! I think that is the most perfect and thorough explanation I have seen of why this connectivity stuff just needs to WORK. I will be bringing a printout of this with me to my next meeting with software dev!

So--for your specific issue. Do you have an antenna on your card? It sounds like you've got the newest version of the Fabmo hardware--the two stacked, green pcbs without all of the spliced USB cable mess connecting them.

No matter which version of the board you have, there is an option for adding an external antenna--it plugs into a little round gold connector right next to the Intel board on the card--the antenna is a little stick-on patch that can be either left hanging in the open or attached to the inside wall of the electronics enclosure.

If you don't have one--PM me your address and I will get one to you along with instructions for installation.

In fact--anyone who is experiencing this type of issue may benefit from an antenna and I am happy to get them in the mail to people. It is not the be-all end-all solution to every problem...but it is important that things work as well as possible right NOW.
Re: Network woes
January 23, 2018 12:17PM
Seconded, thank you for the detailed information. I'd like to get a little more info so we can help with your problem. The fact that the ethernet connection doesn't work is suspicious - we typically find that to be extremely reliable, and the device *should* be able to update itself on this connection - it is in fact the most reliable way to do so, so this is as good a place as any to start troubleshooting your issue.

Can you answer a few questions?

1. What is the security strategy for your wireless network? (Are you WPA, WPA2, something else?)
2. When you connect the ethernet, what IP address is the tool assigned? When you say that the tool can't update in this configuration, how long are you waiting for the update to download (1.6.x is a substantial update, and the download can take a while on some connections)
3. Where are you located, physically, if in the united states (city, state)
4. Do I understand you correctly that there is no AP broadcast only while you have ethernet plugged in? Or is there never an AP broadcast?
5. How are you finding the tool on your network? Are you using the FabMo tool minder, and if so, what platform? (Windows, mac, iOS, android?)

We'll get you cutting again. Being off in the weeds when you're trying to be doing projects is no fun. I am sorry for all the trouble you're having.

Re: Network woes
February 04, 2018 05:09PM
I truly feel your pain, last summer I spent several long nights fighting to get my Handibot on my network, to no avail. Fortunately for me, AP mode still works (touch wood), although it too can be flaky! Far too often I get the famous "waiting for FabMo" message. In the worse cases it results in project material joining the firewood pile.

One of the reasons I sold my v1.1 Handibot and purchased a v2 was to get away from the USB cable, which was not only constantly in the way, it tended to get knocked loose at the wrong time. Wireless connectivity was a big selling point of the v2 at least to me. Most of the CNC routing I do is in my workroom that has an Ethernet drop, but I also do work on location where Ethernet connection seldom exist. So, I have yet to hardwire the FabMo.

Besides the availability of Ethernet connections, I also have not ventured into hardwiring because the Ethernet document implied you needed an Ethernet/USB Hub. I did notice the RJ45 connector on the back of the FabMo but was not sure if it was Ethernet or just looked like it. Sounds like you were more willing to experiment than I in that respect. Thanks for that! I agree with your implied sentiment that schematics or description of all the ports/connectors on the FabMo would be a nice thing to have.

Hopefully someone will to update the "Hooking-Up to Your Tool Using Ethernet (option)" document.

It would be interesting to know if hardwiring the FabMo resolves some of the issues Daniel Block was having with 1.6.x FabMo firmware versions.

To add one thing to your analysis, when my v2 was running 1.2.x firmware it could join my WiFi network but dropped often and usually at the most in opportune time. When I moved to 1.4.2, my v2 is no longer willing to join my WiFi, it sees the network and you can select it to enter the passphrase but then it just disappears only to reappear in AP mode a few minutes later. I have verified in the access point logs that it never attempts the connection.

I have used Dr. WiFi and AR signal master to test and map the WiFi signal in my workroom. I placed the Handibot where the signal was strongest (-31dBm to -35dBm). Just as a point of reference -30bBm is about the best you can achieve and anything above -65dBm is considered a strong signal. To achieve a signal of -30dBm you need to be within a couple of feet of the access point, because my access point is on the ceiling the closest I can get is around 3.5 feet. So, I can tell you signal strength is not the issue. What is interesting is the AP mode the signal strength at the side of the Handibot is only -47dBm, not weak but lower than I expected.

Brian Owen's point about the external antenna is interesting and I hope my PM got through to him. If the external antenna solves the issue I wonder if the Handibot power supply is causing too much electrical interference and may need to be shielded better.

I hope to get a change to test some more with an external antenna and maybe test the 1.6.x firmware when hardwired. That is, I am seriously considering hardwiring when doing longer run jobs and possible when working on material I cannot replace.

Brian, or anyone else, can you please verify that the RJ45 on the FabMo when used for a hardwired Ethernet connection does not cause any other issues/limitations?

Thanks, in advance,

Re: Network woes
February 05, 2018 01:18PM
I was just talking about this with someone over the weekend (The ethernet connectivity). It should be possible to plug directly into the ethernet port on the newer fabmo cards (the double-decker boards with two green pcbs stacked)--however there is a driver that needs to be installed on the edison to make it work--that was where we left it last night with the intention to talk with the software team about it today.

For the older cards--Ted has taken to carrying a little mini router around with him for that purpose...cludgy I know but not too space consuming. I'll find out what he's using.

Thanks for recording those stats for the wireless signal--I'll make sure that other people come take a look at the work you've done to see if it is helpful for their development.
Re: Network woes
February 11, 2018 11:13AM
I have en early version of FabMo-Edison (#30), up-dated to version 1.6.0. I can connect via AP both to the Updater and the Dashboard.
I can also connect via Ethernet with the Satechi USB/Ethernet device. I can connect to the FabMo Edison via ssh and also to the Updater via the port 81.
So far so good, but when I try to connect to the engine either directly by doing [] (the address given to the Edison by my router) or hitting Goto Dashboard in the Updater, I’m unable to access the Server login and instead I got the following message:

{"code":"ResourceNotFound","message":"/cgi-bin/luci; caused by Error: ENOENT, stat 'dashboard/build/cgi-bin/luci'"}

Please help me tho troubleshoot and solve this problem.
Best regards, Miguel
Re: Network woes
February 12, 2018 11:26AM

/cgi-bin/luci is not a URL that is associated with fabmo in any way - what browser are you using, and do you have any extensions installed that might be requesting this resource?


It looks like this might be part of a software add-in for dd-wrt. Are you sure that your DHCP is working properly, and not mistakenly assigned 10.102 to more than one client on your network?

Re: Network woes
February 13, 2018 12:01PM
Just an FYI. I doubt my problems were network related. It was freezing mid-job. I also didn't have mine connected to a network at the time (all adhoc). I've also since modified my handibot with an external antenna too. It works, but it still is not perfect.
Re: Network woes
February 28, 2018 07:44PM
Thanks for your response. I don’t have access to my Handibot now and I will not be able to run any test for the next month or so. As soon as I can I will check again and look for what you suggest; I do have an Openwrt type of router so the problem may indeed be related to the router. I will let you know my findings.
Best regards, Miguel
Re: Network woes
April 03, 2018 06:52AM
I was finally able to test again the Ethernet connection to a (non Openwrt) router and I can confirm that everything works perfectly. So if you are experiencing WiFi problems the Ethernet connectivity is an excelent alternative.
Re: Network woes
April 03, 2018 10:17AM
Agree! I've been really impressed by the responsiveness of the tool on ethernet. I have been using my lenovo tablet (which has ethernet connectivity through its USB-C port with a converter) and been really happy. Only shame of it is, tablets can't be connected and charging at the same time (ethernet uses the charging port) so you can't leave it permanently connected.
Re: Network woes
April 06, 2018 10:13AM
Brian, have you had any luck getting ethernet working on the Sparkfun board set? The Green PCB does have a RJ45 connector but I have not been brave enough to try attaching it to my router. Really more time constraint than fear but I don't want to screw up the FabMo or the router.

Thanks in advance,

Re: Network woes
April 06, 2018 10:34AM
That should be all it takes really--there isn't any risk of screwing up the router (FabMo will screw itself up regardless so it can't hurt, lol) I would suggest you give it a try. If you connect the ethernet cable direct to your computer--you should be able to locate your tool at the IP:
Re: Network woes
June 18, 2018 10:04AM
I tried plugging in to the ethernet on the Board, and I got nothing. Is there are driver I need to install? I also understand I can plug in a USB ethernet device, but can I also plug directly into the ethernet jack that is currently on the board?
Re: Network woes
June 20, 2018 04:50PM
Couple things in review about ethernet--
you'll need to be on FabMo version 1.6.0 or above.
once you connect to the tool--you'll find the dashboard at (rather than the usual
It may help to use one of those USB to ethernet adapters--I've had good success on customer computers with those.
Re: Network woes
June 21, 2018 04:17PM
Hey Daniel,

If you have a FabMo card with the red Edison carrier on top then you have to use the usb-2-ethernet hub dohickey. What looks like an Ethernet jack on the lower board is actually an early method to connect peripherals like switches to ShopBots.

If you have a newer style FabMo card without the red board on top then you can plug your Ethernet cable into the jack on the top board and be able to connect.

Re: Network woes
August 23, 2018 06:30PM
I'm having a hell of time with this. I've tried like 4 different adapters, none of them work. I even ssh'd into the device to make sure. The are recognized by the kernel, but don't show up in ifconfig.

Can someone provide a link to one on amazon that is currently for sale that actually works?

This one does not work: [satechi.net]

I also tried this one, and it didn't work: [www.amazon.com]

That surprised me, because it looks liked RTL8153 was included in the kernel based on what I saw on github.
Re: Network woes
August 24, 2018 09:02AM
The Satechi ST-U3B1NI is the one I've used and know it works. Unfortunately I couldn't find this exact one on Amazon and more....there's a new version with a few changes that may or may not work. Their new aluminum-bodied replacement doesn't work for me as you've already figured out!


If you can't find one I've got an extra.. Send me a message with your mailing address and I'll send it off.

Re: Network woes
September 21, 2018 01:42PM
Given that the Satechi ST-U3B1N has been discontinued and is generally unavailable (at a reasonable price, I saw only one vendor who asking $80) has anyone found an alternative for the red Edison (Sparkfun board set)?

I am kicking myself for not getting one earlier, life introduced some other challenges and fixing the Handibot network issues fall off my ToDo list.

If no alternative has been found is there an option to trade up to a newer FabMo?

Thanks in advance,

Re: Network woes
October 06, 2018 09:59AM
Even the one vendor I found is out of stock, they sent me an aluminum version which did not work. I search elsewhere to no avail.

Has anyone found a working alternative for the Sparkfun board set?

Thanks in advance,

Re: Network woes
October 10, 2018 03:14PM

I found one in a bin here at ShopBot! Since I only have one I'll be auctioning it off to the highest bidder, bidding starts at $90!

...Just kidding, since you've been working so hard to find one, I'll send it to you for free--just PM me where you want it sent. I know other people need these as well...so I'll keep digging for more.
Re: Network woes
October 15, 2018 02:14PM
On the next Fabmo software update, can you also update the kernel to include a few more network drivers? I would imagine that would also solve the problem.
Re: Network woes
October 15, 2018 02:22PM
Sounds like a question for Sturmer! I'll ping him about it.
Sorry, only registered users may post in this forum.