Go Back to handibot.com
sign up or log-in


Router will not switch on

Posted by Wazza 
Router will not switch on
January 25, 2018 02:36AM
I have not been able to spend time with my Handibot since about Christmas due to other more pressing matters, but now that I do have time free I find that I still can't use it.
Much trouble was encountered when updating the Fabmo desktop software failed, eventually necessitating replacement of the Edison board. After doing that I ran the “Home” and “Park” routines and checked that it zeros the X and Y axes correctly.
Then I upgraded to the Large Sheet Tool with the Quick-Bit Z zeroing plate, and once again checked to ensure the “Home” and “Park” commands worked OK. Due to some discussion on the forum re problems with Quick-Bit I chose to not try it at that time. All these short tests were performed without the router being on board.
Now that I have installed the router I once again ran the “Home” command, then the Quick-Bit app. The downwards travel did not cease when the bit contacted the pressure plate.
I switched the Handibot off, re-started, zeroed Z manually and attempted to cut a file.
The router does not switch on. I have looked for any poorly connected wires, etc.,
I have tested the router independent of the Handibot, it works OK. I have also checked the file and seen that it contains the code to turn the router on.
Where to from here?
Re: Router will not switch on
January 25, 2018 09:38AM
When you say the router does not switch on--is the file continuing to run with the router off? Or is the file exiting without running the cut?

I recently put together a troubleshooting doc for hardware issues that could be preventing a router from starting--everything from worn out brushes to electrical issues--it is attached to this post, so if you give it a quick read it may help us narrow down what is causing your issue.

I'm planning to do a little write-up today on the forum about a long support call that I had yesterday with a customer who had a handibot that refused to run certain jobs...it was a very strange problem and we checked everything from macros to fabmo version to unit values and tool profiles...it ended up being that for extremely long files, the authorize feature was bugging out in FabMo 1.6.0 and above. Turning off authorize in the Machine Configuration menu would allow the long jobs to run...that bug has been reported to software team.

For the Quick-Bit--the function has been complicated by the recent software update (as you may have noticed from some of the other threads). The first thing to check is whether input #5 is lighting up when you press the pressure pad--input status is displayed below the position readout on the red side bar (right side of the screen). If input #5 is not lighting up (or is lit up before you press on the pad), then there is a mechanical issue with the quick-bit which I can help you work out. If the input is working normally then there is an issue with the routine the is running the quick-bit--and the fix depends on your software version.
open | download - Handibot 2 Troubleshooting-Router Does Not Start.pdf (198.4 KB)
Re: Router will not switch on
January 29, 2018 02:23AM
Hi Brian,
The file is continuing to run, it's just the router isn't being switched on. The router is OK, I have tested it away from the Handibot and it fires up as it should when 240VAC is applied.
The clicks from the relays don't happen nor does that green light come on when the router is supposed to power on.
Re: Router will not switch on
January 29, 2018 03:42AM
Re Quick-Bit, the lights are normal. Input 3 lights up when Handibot is on, input 5 lights up when I press on the pressure plate with my finger. the software I am running is the latest issue.
Re: Router will not switch on
January 29, 2018 02:36PM

It could be a bad relay on the interface board...but first we should check for a software problem. The router turning on is controled by Macro number 6--you can view your tool's macros from the dashboard by clicking the folder icon on the left. The contents on Macro 6 should simply be: "SO1,1" a command which just means "turn on output #1" this triggers the little relay with the green light on the board which passes 24V to the big relay that sends power to the router.

If that macro isn't there...perhaps you need to switch the profile that your machine is using (this is a new feature, which I think has been a little confusing unfortunately...) profiles are set from the first page in the configuration menu. There's a drop-down menu for machine profile where you'll need to select Handibot 2 (or Adventure Edition or Large Sheet Tool). This should populate your macros which should allow the tool to run. If this is the case...then I suspect your quick-bit troubles may be related to that as well...

Re: Router will not switch on
January 29, 2018 08:52PM
Fabmo is configured correctly, and macro #6 is as you describe.
Re: Router will not switch on
January 30, 2018 02:59PM
Thanks for checking. If the router works, and the commands to start the router are correct...plus you aren't seeing a light that indicates the relay is closing...I would suspect that the relay has been damaged. However, the handibot interface board supports control of two routers--so there is, in effect, a backup relay that can be used to control the router. Hopefully that second relay was not damaged.

I've put together a document describing how to switch your router control over to the second relay. It is attached to this post.
open | download - Handibot 2 Troubleshooting-swapping router output.pdf (564.1 KB)
Re: Router will not switch on
February 01, 2018 07:03AM
Handibot is now ready to rock 'n' roll, but I haven't yet tried the Quick-Bit app, that's the next step.
I doubt that switching the router control would affect the app, but you never know your luck in a big city!
Will have at it tomorrow morning.
Thanks, Brian, for all your help.
Re: Router will not switch on
February 01, 2018 09:24AM

I think the Quick-Bit problem is still something to do with software--which I'm still working on figuring out. Glad the relay swap worked! I usually send out a new interface board for that problem--but it occured to me that it might be easier to just use the spare that you've already got!
Re: Router will not switch on
February 01, 2018 02:56PM
glad your up and running Wassa, and glad to hear we are working on quick bit app thumbs up
Re: Router will not switch on
February 05, 2018 01:26PM
Wazza we're looking into this problem more deeply here--We've had 5 units with failed relays like yours...all have been international tools.....so that makes me think it has something to do with the power being supplied...The power supply in the back of the handibot is auto-switching so it will change to 220V mode with no problems. It outputs 24V to power the board which is then stepped down to 5V by those two silver power supplies on the interface board. The 5V is used to flip the relay on the board to send 24V to the bigger relay that flips the 220VAC...

Could be that the big relay is sending something back to the small relay, causing damage...or it could be that the incoming power is damaging it somehow....the other possibility is that the 5V coming from the power supplies on the board is insufficient to run the FabMo card, the LED strip and the relays....this definitely isn't the case on 110VAC here....but there may be some variable that we aren't thinking of. I'd be curious...if you're ever bored and feel like helping us explore this...if you moved the router back to relay #1 (adjusting the macros back as well) and also unplugged the LED strip (that 3 pin connector that branches off the ribbon cable on the FabMo card), would the relay work correctly?
Re: Router will not switch on
February 07, 2018 01:31AM
I just tried switching back to the original relay and disengaging the LEDs, but no dice. The router doesn't fire up.
Re: Router will not switch on
February 12, 2018 10:25AM

Thank you so much for checking that for us...was hopeful that we'd found the root cause but we'll have to keep searching! Glad that the alt relay is working though.
Re: Router will not switch on
February 14, 2018 06:18AM
I am still having troubles. These issues are surfacing slowly as I haven't been able to spend the time I would like on the Handibot.
Today I created a simple file, just a profile cut on a 6" x 8" square. Firstly, the SBP file did not know that I was running my router from the "backup" relay, so I edited the file to fix that. It also did not zero the Z axis correctly. The router would then switch on, but after moving to the start point it shut down as if it had finished the cut.
I have Aspire 9 as well as V Carve Pro 9 and if I generate an SBP file in each using the same CRV file, they use different codes.
I have tried to run jobs that I created some months ago and knew that they were ok, but now I have the same problem.
In all the changes I have made to my Handibot (upgraded Fabmo, Long Sheet Base, replaced Edison PCcool smiley I fear I may have failed to re-calibrate something or missed something that I was meant to do.
Any ideas?
Re: Router will not switch on
February 14, 2018 10:09AM
Ah--when you upgraded FabMo (or changed profiles) that would have reset the router start and stop macros. The beginning of an SBP from VCarve should have a C6 command which will call macro #6 to start the router. Make sure you're in the Handibot profile (set from the configuration screen) and then double check that macro.
Re: Router will not switch on
February 14, 2018 10:10AM
I'll talk to the software guys about how to install a custom profile that will save your settings that way--so you don't have to worry about something getting messed up.
Re: Router will not switch on
February 18, 2018 01:05AM
Today I had another play, trying to get my head around these issues. In the middle of all this, an upgrade for Aspire rocked up, so I ran that before doing anything else.
Then I edited the SBP file that wouldn't run by changing from the form tool I was trying to use to a 1/8" EM. The file ran, no sweat!
Upon inspecting the data for the form tool(I had installed this tool myself) I noticed that the tool was given tool number 1, and that clashes with another tool in my arsenal. I gave it tool number 200, changed the SBP file back to this tool and it worked. So, I ran the Quick-Bit app, and it worked too!
Will wonders never cease?
Just another parameter to consider when troubleshooting, hope this helps someone out.
Have a nice day and about 35 million beers.
Re: Router will not switch on
February 18, 2018 06:51AM
what did you do to get Quick bit working. I don't have aspire. would be nice to have more than a 200. paper weight winking smiley
Re: Router will not switch on
February 18, 2018 05:52PM
Hello, rasbldrs,
I only changed the tool number to an unused number and following that the Quick-Bit app worked I doubt that the Aspire upgrade had anything to do with it, as the changes noted in the release notes don't mention this problem.
Re: Router will not switch on
February 22, 2018 02:24PM
Hey guys--sorry it took me so long to get back to this thread.

I'm working on the quick-bit app today. I've got my tool here, loaded with 1.6.1 and the most recent app from my wiki page: [sites.google.com]

input #5 lights up when I press the quick bit and turns off when I let go.

Running the second macro in the app (listed as for 1.6.0 and above) works as expected.

Now I'm going to downgrade my tool to 1.4.2 and try the other macro. Will report back in a sec!
Re: Router will not switch on
February 22, 2018 02:54PM
Ok I've upgraded and downgraded and upgraded again to test the app--I've made some changes to the app so you should go download and install the new version from the wiki page. I liked being able to just run the routine with one click without having to install a macro--but I think that the macro install and then run method is going to be the most foolproof through all versions of FabMo...so I've changed it back to that. Let me know if you have any issues with it.
Re: Router will not switch on
February 23, 2018 01:13PM
Thanks Brian I have installed the new Quick bit app and I have success. One question, at the end it says zeroed and cutter length saved quit or resume. What one do you pick and what is the difference?. Bob (a happy camper now.)
Re: Router will not switch on
February 23, 2018 02:01PM

It shouldn't matter which one is picked. The way that pop-up messages are written into ShopBot code is by writing our message and then inserting a PAUSE--the pause prompts a popup message that always has two options--resume or quit (it was originally used for things like bit changes and stuff). At that point in the routine, all of the system variables have been updated. You could even go into the macro and delete that message and not have to see it anymore.

VA,,, $z_backoff + &ZZeroPlateThickness + 0.5
' Read in current System Variables for current Z and Z-tablebase-offset
&tempTB_Zoffset = %(8)
' Reset current_cutter and Set Table Base Coordinates and Location to 0 for Z
$current_cutter_Zoffset = &tempTB_Zoffset * -1
PAUSE "Z-ZEROED and Cutter Length Saved."
Sorry, only registered users may post in this forum.