Go Back to handibot.com
sign up or log-in


Fabmo completely broken now

Posted by stevempotter 
Fabmo completely broken now
March 23, 2018 07:21AM
After a failed update, my Handibot is now completely unusable. Fabmo only shows one screen (see attached) and none of the links work. How can I get Fabmo and the Hadibot back to a usable state?
I tried power cycling several times; nothing changed.
I will attach also the log text of the failed update...

open | download - Fabmo update log errors POTTER 3-23-18.txt (56.7 KB)
open | download - Screen Shot 2018-03-23 at 11.06.03 AM.png (113.7 KB)
Re: Fabmo completely broken now
March 23, 2018 11:06AM

Ugh! What a mess--I'm really sorry about that. I think that the best way to proceed is to manually load a more recent version of fabmo onto your card by directly plugging it into your computer. The doc here: [docs.handibot.com]
describes the process for performing a reflash from your PC. This will take you to version 1.4.2 which is a stable and reliable release. From there you can perform the 1.6.2 update if you wish or simply continue running in 1.4.2.

Re: Fabmo completely broken now
March 23, 2018 01:00PM
Thanks for the quick reply, Brian.I am assuming you don't have a flasher for MacOS X?
I will attempt with Vmware Fusion, because I do not have access to any PCs (We are a Mac-only household)
If you or anyone has any particular advice on how to deal with COM ports or USB settings in VMware, please let me know.
On Mac OS, this stuff is all automatic.
Re: Fabmo completely broken now
March 23, 2018 01:49PM
OK, I am making progress but need help. I got the VMware emulation of Windows 7 talking to the Edison card via the USB, after installing the driver as advised in the instructions.

But when I run the Flash.bat I get a "UNC paths not supported" error. (SEE ATTACHED SCREENSHOT)
I assume that means I have to move some files somewhere or set default paths?
Please provide detailed instructions, knowing I am not a Windows person.
And you might add those to the instructions PDF, too.

open | download - Screen Shot 2018-03-23 at 5.37.34 PM.png (121.5 KB)
Re: Fabmo completely broken now
March 23, 2018 02:01PM
More progress: I copied the Fabmo zip folder to the root level of C:\\ and tried to invoke Flash.bat there.
Yay! It ran....for a second. Then I plugged in the Edison and it exits with an
Exit Code 74 (See attached screenshot). I have no idea what that means.

Any advice?
open | download - Screen Shot 2018-03-23 at 5.57.15 PM.png (90.3 KB)
Re: Fabmo completely broken now
March 23, 2018 02:15PM
Here's a couple more error messages upon retrying the Flash.bat. I got a little bit further, but I don't know what
"Invalid DFU suffix signature" is or how to fix that.
open | download - Screen Shot 2018-03-23 at 6.07.47 PM.png (68.7 KB)
open | download - Screen Shot 2018-03-23 at 6.03.39 PM.png (81.8 KB)
Re: Fabmo completely broken now
March 26, 2018 05:10PM
Hey Steve--I'm afraid I'm not going to be of too much help here...but I've gotten in touch with one of the programmers that uses a mac for development. He should be in tomorrow and able to answer your question.

Re: Fabmo completely broken now
March 27, 2018 08:09AM
Thanks, Brian, that will be great to get some help. Until then, my beloved Handibot is just an expensive doorstop!
Re: Fabmo completely broken now
March 27, 2018 01:42PM

Sorry for the delay in responding.

I would sooner have had you reflash on a mac, but since you're this far along on windows, let's keep on this route.

Can you tell me this - and this is going to sound silly - How long is the cable you are using to reflash your board? The error 74 you're getting is indicative of a bad transfer, which may be resolved by a shorter (or even different) USB cable.

If that doesn't work, there's plenty else we can try. Don't worry, we'll get your tool moving again.
Re: Fabmo completely broken now
March 28, 2018 02:01PM
Hi Ryan,

For the above attempts, I was using my shortest, shielded USB cable (19"). I just tried another one, about the same length, and got the attached error message.

If it is possible to reflash using my Mac OS, please tell me how, because I think my problems are due to delays with the Virtual PC getting the USB connection to Edison working.

open | download - Screen Shot 2018-03-28 at 6.55.56 PM.png (36.2 KB)
Re: Fabmo completely broken now
April 01, 2018 06:18PM
Steve! I have to aplogize for not seeing above that you're actually doing your windows stuff in a virtualizer, and not on a hardware windows machine. I am a huge advocate for using VMWare etc. for things like VCarve Pro, etc. But in this one particular instance, due to the way USB devices are enumerated when they are connected/disconnected, it's virtually (hah!) guaranteed not to work for this reflash operation.

Fortunately, there's a mac reflash script included in the package you've already downloaded. I do all my development on a mac, so this is a process that's familiar to me. There are a few steps however, which are detailed below:

Install Homebrew
You need to install homebrew for the script to work. You can skip this if you have homebrew installed already.
/usr/bin/ruby -e "$(curl -fsSL [raw.githubusercontent.com];

Install prerequisites
There are a few tools that are required by the reflasher that you can install with homebrew:
brew install dfu-util coreutils gnu-getopt

Make the flash script executable
In some versions of the reflash package, the actual flashall.sh script is not executable. Mark it so with the following command:
chmod +x ./flashall.sh
(You have to do this in the same directory that the flashall.sh script is located.

The sudo may not be necessary, depending on the version of macos you have, but it doesn't hurt, in any case.
sudo ./flashall.sh

The reflasher will prompt you to "plug and reboot the board" - when it does so, that is the time to plug the board in - just execute the same procedure that is described in the document above for the windows reflasher, and you should be back on the water in no time!
Re: Fabmo completely broken now
April 04, 2018 03:49PM
Hi Steve,

I've used Etcher on my MAC to flash USB and SD card images and it works great! You can find it here:


Hope that helps,

Re: Fabmo WORKING now
April 06, 2018 06:14AM
Thanks, Ryan, for your instructions on using a Mac to do re-flashing of the Edison, and thanks, Mark, for telling us about Etcher.

I will use those tools next time I need to flash something.

Being completely stuck for over a week (I asked here if there was a Mac flasher on Mar 23), I got a refurbished PC laptop with Win10pro and this re-flashed correctly on the first go, with no errors. Yay! After another round of updating, my Handibot is now working with Fabmo 1.6.2, which seems a lot less buggy than the old one I was using.
Perhaps you could add info about the Mac reflashing to the instructions PDF you have on your Doc site.

Thanks again,
Re: Fabmo completely broken now
April 06, 2018 10:32AM
Glad you're up and running again Steve...and I really hope your class goes well. I'll be monitoring the forum and twitter--if you need any help during your class just let me know!
Re: Fabmo completely broken now
May 25, 2018 11:58PM
I've run into a similar issue while attempting to update my Handibot. I'm now at a point where I need to re-flash my board because of a botched update. I'm using a Mac and I'm wondering if someone could point me to the download mentioned above where I can find the reflash.sh script.
Re: Fabmo completely broken now
May 27, 2018 11:47AM
Hey Jesse,

The .sh file is included in the same zip file with all the Windows reflash files. The link is on page 6 of this doc:


Sorry, only registered users may post in this forum.