Go Back to handibot.com
sign up or log-in


Drill not turning on even though code tells it to?

Posted by tim_jackins 

I'm an IA at Charlottesville High School and I've been tasked with figuring out how highschoolers could use our Handibot to cut custom PCBs. I bought bits, engravers, and copper boards from here. I have been using Fritzing to generate Gerber files and Carbide Copper to turn those Gerber files into G-Code (in a .nc file). Here's my problem: whenever I run the file on my Handibot it never turns the drill on. If I let it, It follows the correct paths but drags the engraver across copper instead of spinning up and engraving properly. I really don't want to break my bits, they sure were expensive, so if anyone has any suggestions I'm open to them.

P.S. Lmk if I should post any other files of pictures.
open | download - samp-in.nc (55.3 KB)

I just tested your file on a handibot here in the shop and the router did turn on. I'm attaching a document that goes through steps for troubleshooting a router not turning on.

My other question is: what version of FabMo are you running? This can be found by opening the configuration menu and looking for a number in the top, right hand corner of the page.

open | download - Handibot 2 Troubleshooting-Router Does Not Start.pdf (198.4 KB)
Brian Owen, ShopBot Wrote:
> What version of FabMo are
> you running?

I can check the version when I get back into work Tuesday (9/4).

The reason this has been confusing is that when I run other files on my Handibot the router turns on and it works fine. I'm happy to know that the file works. I'll reply again once I check the version.

Ah! That’s great news! I was concerned that there was an electrical problem.
Try changing the spindle start command in your file from M03 to M04. The spindle can only rotate in one direction and the M03/M04 commands are just used to flip a relay that sends power to the router. I think it was an oversight in some early versions of FabMo that both commands did not work. Updating should solve the problem. If you let me know your version I can tell you how to get the files you need for updating.
The M03 > M04 fix worked! the spindle is spinning up; however, there's a new problem: it isn't pausing for a tool change. The software version on my Handibot is 1.4.2.

Tool changes weren't yet implemented back in V1.4.2 -- for SBP files they are available in 1.7.1 and later--but it would be best to queue up your jobs, separated by tool type in your job manager.

Sorry, only registered users may post in this forum.