Go Back to handibot.com
sign up or log-in


Quick Bit App

Posted by rasbldrs 
Quick Bit App
December 26, 2017 01:10PM
I installed quick bit this morning and when I push the button the router does not stop it lifts the handibot up. Everything went well with install until it says you must install macro prior to first use push blue button that says install macro, I don't have a button that says that just two green buttons saying Measure Cutter Fabmo verison 1.5.2 and earlier, and Measure Fabmo version 1.6.0 and later. I pushed 1.6.0 and just keeps going does not stop? How do I install the macro, under macros their is one there but that is the old one with alligator clip.
Re: Quick Bit App
December 26, 2017 04:55PM
I've had to update that app a couple of times to get things working right--sorry about that. The latest version is stored on the wiki here: [sites.google.com]

There were some nuances to the way the new version of fabmo handled shopbot code that I hadn't yet learned. The good thing about the new version is that you can execute code directly from an app without needing to install a macro. That's why there is no macro install button in the new version of the app.
Re: Quick Bit App
December 26, 2017 06:54PM
Thanks Brian, Downloaded new file deleted old one. Now when I push button 1.6.0 it stops hard on the quick bit and freezes as per picture it will not let you stop the only way I can reset is get out of fambo and turn off handibot. where do I go from here?
open | download - quick-bit.JPG (103.7 KB)
Re: Quick Bit App
December 27, 2017 09:55AM

There should be another update available to 1.6.1 if you check in your configuration menu--I know that there was some talk of fixing odd behavior with stopping in the update--I think that it would be good to make that update. ( I know updating has been a bit harrowing for people lately...but the 1.6.0 to 1.6.1 update is much less extreme and shouldn't cause any hiccups).
Also there is now the option for "profiles" depending on what type of tool you have. The profiles load a variety of settings, apps and macros. You'll want to make sure that you've got "Handibot 2" selected. The "Default" profile is missing some macros which can cause problems for homing.
Thanks for your patience!!!

Re: Quick Bit App
January 01, 2018 07:07AM
Update on Quick bit app. I updated to 1.6.1. and everything working now Thanks and Happy New Year
Re: Quick Bit App
January 14, 2018 04:00PM
Went to use Handibot and quick bit freezes everything again. Once the bit hits the metal on the quick bit every freezes and the only way to get going is to turn everything off and restart. What's up how can we fix this...
Re: Quick Bit App
January 15, 2018 02:30PM
Hmm--have you checked to see if input #5 is lit before the routine starts? The routine should be checking for that...but if for some reason the routine runs and input #5 is already closed...that could cause an error.
Re: Quick Bit App
January 15, 2018 05:43PM
Not sure what you mean by lit I do not see any lights by 5? Can not get it to do anything once it hits the quick bit puck...
Re: Quick Bit App
January 15, 2018 06:40PM
Sorry I am not where I can provide a screenshot but over on the right near where you drive the axis around there are some input/output lights. They will be green or red depending on their state. To find them, push the red stop button and one of these will flash red and then go back to green when you release it. So, on that row of red and green lights, if #5 is already red things are not going to work right. It should be green, turn red just as the bit taps off and then go back to green.
Re: Quick Bit App
January 15, 2018 07:46PM
I don't have lights change when I push the red button. attached are the only lights I see be sides by the on off switch there are 2 green lights. I have no idea...
open | download - lights.JPG (95.1 KB)
Re: Quick Bit App
January 15, 2018 07:55PM
On the web interface, aka dashboard. Over near the other controls on the right. I don't think there are hardware lights for this.
Re: Quick Bit App
January 16, 2018 10:16AM
Oh yea--I'm sorry about that.
Here lemme post a screen-cap of where to look for input circuit closure.
The status bar highlighted in the screen-cap gives you the status of all inputs on your tool.
Input #5 is the input associated with your quick bit and it is set to "normally open" meaning that it only lights up white when the plate is pressed --which closes the circuit--and gives the tool the signal to stop and zero out the z axis.
You should be able to press on the quick-bit with your thumb and cause this indicator to light up.
If it does not light up--or if it stays lit up when no pressure is applied to the quick-bit...then that could be the source of the problem.
open | download - Inputs.png (205.8 KB)
Re: Quick Bit App
January 16, 2018 05:29PM
OK got it. I have attached 3 pictures first one machine on just 3 lit, 2nd picture me holding pressure on quick bit, 3rd when bit hits the puck and freezes I have no idea what do you think... Bob
open | download - quick-1.JPG (94.2 KB)
open | download - quick-2.JPG (94.3 KB)
open | download - quick-3.JPG (101.4 KB)
Re: Quick Bit App
January 16, 2018 06:10PM
I had the same problem
Re: Quick Bit App
January 16, 2018 08:16PM
#5 is off until pressure on quick bit puck, freezes as soon as touches puck with #5 lit
Re: Quick Bit App
January 17, 2018 09:31AM

Was this one of the problems you had with 1.6.1 that was fixed by reverting to 1.4.2?
Re: Quick Bit App
January 18, 2018 04:22PM
Yes. This was one of them. I can't remember if I tried it again on 1.4.2 or not, I'm guessing it would worked--since it worked before.

If there was a way I could salvage a job after it freezes, i'd be willing to switch back to 1.6.1. But I can't think of any fool proof way. Maybe if there was a way to manually enter the current position of a bit. That way, I could just write down where it was and reset the unit, and reenter it.

Re: Quick Bit App
January 18, 2018 04:59PM
Correcting position like that hasn't been conveniently added to the dashboard yet--but it is actually possible through use of the SB4 app. SB4 is just a port of the old ShopBot software--so it allows you to use the original SB3 commands--one of those commands is VA.
Format goes like this: VA, "new X position", "new Y position", "new Z position", "new A position".
So if your position before a crash was X=5, Y=3, Z=0.5 -- you'd go to the command line in SB4 and enter VA, 5, 3, 0.5 and it would set the values in the position readout to 3,5,0.5
Super clumsy cludge...but whenever I get a hangup like that I'll quickly jot down my current position just in case I have to do this.

I've had to go through a couple of versions of the Quick-Bit app while I adapted it to the new 1.6.0 release and there have been changes as recently as December 26--so it might be good to try installing the latest version for 1.6.0 users: [sites.google.com]

However--for 1.4.2 users the original app from the webstore will work best.
Re: Quick Bit App
January 18, 2018 05:15PM
So for now I am stuck until you find a software fix?
Re: Quick Bit App
January 18, 2018 05:18PM
went to the above link to see if I have the latest download clicked on the down arrow and says download not available?
Re: Quick Bit App
January 19, 2018 04:38AM
Download link worked this morning, but same one that I have already sad smiley
Re: Quick Bit App
January 21, 2018 06:25AM
So this thing is only good for a door stop?
for some one who knows programming can it be that hard? just frustrated here.
Re: Quick Bit App
January 21, 2018 01:46PM
rasbldrs—the latest app has correct code for the routine—but I believe that the cause of the hangup on your tool is related to the FabMo control software. I know enough to do a little trouble shooting but my area is the design of the tool...I am equally frustrated with the software and am trying to move work along on correcting these problems. The latest release has proven to be more trouble than it is worth—so I agree with Dan in saying that downgrading to 1.4.2 is the most complete solution we currently have.
Re: Quick Bit App
March 04, 2018 06:45AM
As I said in another post Brian did update the app and in trying it worked great. I was cutting yesterday and it would go down and touch, lift up, and touch again and freeze up the machine. This went on and on. I manually set the Z and did some cutting. Before I shut the machine down thought I would give one last try and it worked. Why would it be so spotty? I thought we had it... Bob
Re: Quick Bit App
March 05, 2018 11:43AM

Check out my response in the stop button thread--I think that these two things are related to the same issue of connection latency. I've never been happy with the wireless response time on FabMo and I think that direct connectivity is going to be the best way forward here. We've been so intent on eliminating the tether but I think that the performance improvements from a direct connection make it absolutely worth the extra effort.

Re: Quick Bit App
April 04, 2018 02:02PM
Quick Bit on Handibot V.1
The Quick Bit Pressure sensitive Z Zero Plate User Manual describes the installation of the QB in a Handibot Adventure. In pictures 11 shows the input connections on the interface board and in number 12 tells to connect QB black wire to GND and red wire to IP5.
I have a Handibot V.1 with an different interface board. The inputs on my interface board are labeled GND, IP1, IP2...IP4 an +5; no IP5. Only IP1 and +5 are free.
Does the Handiboat V1 interface board have an (electronically) equivalent connector to the IP5 on the Handibot Adventure?
It’s possible to connect the Quick Bit to either IP1 or +5 in the Handiboartd V1 interface board? Which one is recommended?
Re: Quick Bit App
April 04, 2018 04:01PM
You can use input #1 (handibot v2 has inputs up to 8).
You'll just need to update the macro (code snippet) that runs the routine. I'll attach the updated routine here.
open | download - Handibot 1 Quick-Bit.sbp (2 KB)
Re: Quick Bit App
April 04, 2018 04:21PM
Thanks Brian!
Re: Quick Bit App
April 05, 2018 01:45PM
I reviewed the code and noticed that the second line is commented:

' IF %(51) = 1 THEN GOTO Already_Triggered ' *not working yet ...

Wondering about why this is not working, I compared this code to macro_2.sbp code for the Handibot2 and noticed a different form to check the status of input #1.

My question is if there is any special reason not to use it in the code you sent me, like so:

' -------- Main Program Section --------
GOSUB check_input

' --- Subroutines ---

IF %(51) = 1 THEN GOTO check_input_fail

END "Input switch is already tripped. Cannot zero the tool. Move Off Switch and Retry."

I don’t have my Handibot available so I will not be able to give it a try.
Please your comments.
Re: Quick Bit App
April 06, 2018 10:30AM
Actually that bit of code should work now--however, it just needs to be tweaked to look for closure on input #5 rather than input #1

The system variables for inputs are in the 50s range-- so input #1 is %(51) and input #5 is %(55) and of course closure is indicated by a status of 1 and open is indicated by 0 (you can change the default status of a switch in the inputs section of the configurations menu.

Just as a fun aside...I recently put together a routine to home a rotary axis--the "probing" in the rotary axis has not been enabled in fabmo yet...but as a workaround I made an IF THEN loop like this:

IF %(55) = 0 THEN GOTO initializeB

Kind of a kludge but was pretty helpful in getting the tool to do what I wanted until the PB command is available.
Sorry, only registered users may post in this forum.